in Raspberry Pi

Come installare MotionEye su Raspberry Pi

Molto semplicemente eseguite da terminale:

sudo wget https://raw.githubusercontent.com/marcotini/Raspberry-Pi-camera-HomeKit/master/installer
sudo sh installer

E voilà, ora andate da browser all’indirizzo ip (o hostname) del vostro Raspberry Pi alla porta 8765.

Ad esempio http://raspberrypi.local:8765 e inserite username admin e password vuota, cliccate su login e il gioco è fatto!

Homepage di MotionEye su Raspberry Pi

Se la camera del Pi non vi apparisse, seguite questi passaggi.

Scrivi un commento

Commento

  1. Ciao Marco, lo script di installazione si blocca dopo :

    Estrazione di ffmpeg (3.1.4-1) su (3.1.1-1)…
    Configurazione di ffmpeg (3.1.4-1)…
    Elaborazione dei trigger per man-db (2.7.0.2-5)…
    installer: 38: cd: can’t cd to lib/
    –2017-08-31 18:36:41– https://raw.githubusercontent.com/marcotini/Raspberry-Pi-camera-HomeKit/master/Camera.js
    Risoluzione di raw.githubusercontent.com (raw.githubusercontent.com)… 151.101.xxx.yyy
    Connessione a raw.githubusercontent.com (raw.githubusercontent.com)|151.101.xxx.yyy|:443… connesso.
    Richiesta HTTP inviata, in attesa di risposta… 404 Not Found
    2017-08-31 18:36:42 ERRORE 404: Not Found.

    come posso risolvere?

  2. Preparing to unpack pi_jessie_motion_4.0.1-1_armhf.deb …
    Unpacking motion (4.0.1-1) over (4.0.1-1) …
    dpkg: dependency problems prevent configuration of motion:
    motion depends on libavcodec56 (>= 6:11~beta1) | libavcodec-extra-56 (>= 6:11.7); however:
    Package libavcodec56 is not installed.
    Package libavcodec-extra-56 is not installed.
    motion depends on libavformat56 (>= 6:11~beta1); however:
    Package libavformat56 is not installed.
    motion depends on libavutil54 (>= 6:11~beta1); however:
    Package libavutil54 is not installed.
    motion depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
    Package libmysqlclient18 is not installed.
    motion depends on libpq5; however:
    Package libpq5 is not installed.
    motion depends on libswscale3 (>= 6:11~beta1); however:
    Package libswscale3 is not installed.

    dpkg: error processing package motion (–install):
    dependency problems – leaving unconfigured
    Processing triggers for systemd (232-25+deb9u1) …
    Processing triggers for man-db (2.7.6.1-2) …
    Errors were encountered while processing:
    motion
    Collecting motioneye